The User Interface, Your Drawing Environment … and Layers
There’s not an AutoCAD® user on the planet that has their screen configured like the next guy.

You’ll find insights on

Colors, Workspaces, Layers, the Ribbon and several other interface elements in this section.

TOGGLE YOUR WINDOW BACK FROM A DUAL SCREEN
Have you ever taken your laptop home and then launch a command … and realize the dialog box you should be seeing is
on your 2nd screen? At work.
Hold down the Windows key, then hit the   arrow keys until ‘lost’ window appears. I’ve also seen that
you may need to include the Shift key in that combination. Bottom line, you get your window back!

STARTUP INSIGHTS
STARTUP
The STARTUP variable default is <3> and results
in the screen shown at right. Many prefer this
screen because they can choose from a previously
opened drawing.
Configure your template (see coverage of
templates earlier in this chapter), then set
STARTUP to <0>, and AutoCAD begins with your
template, bypassing the screen shown here.

STARTMODE
Beginning in AutoCAD 2016, the Start tab (above) is perpetual; it just hovers there at the left end of the File tabs. If you
would rather the File tabs only include what you’re working on, set the STARTMODE to <0>.

DOCK LAYOUT TABS ABOVE STATUS BAR
Beginning in AutoCAD 2015, the layout tabs
are Inline with the Status Bar.
Right‐click on one of the Model/Layout tabs,
then click Dock Above Status Bar. Now you
have more room for drawings with more layout tabs.
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THE GOVERNING BODY OF WORKSPACES
Word to the Wise: Workspaces.
The way you configure your screen – the position of the Status bar, the visibility of the Menu
bar, and Tool Palettes – can be saved to a named Workspace. The Workspace named
Drafting & Annotation is the default.

GOLD STAR TIP: If you already ‘arranged’ your toolbars or Ribbon, I recommend you first create a workspace
of your current arrangement so you can return to that condition when you’re finished ‘experimenting’.

How to Create a Workspace
1. To save your current workspace by name, click Workspace Switching,
then click Save Current As.
2. Enter a name for the current workspace, then click Save.
As you learn more about the Ribbon, you can come back and update your Workspace.

Display the Workspace Label
Since you can have more than one Workspace, consider displaying the name of the current workspace.

QUICK ACCESS TOOLBAR [QAT]
The Quick Access Toolbar [QAT] – the tray of icons to
the right of the scarlet letter ‘A’ – is the finest feature
for ‘quick access’ to your favorite commands.

Insights
 Click the down‐arrow at the end of the QAT, then turn on some of the
other defaults, such as Match Properties if it’s not on already.



At the bottom of the QAT dropdown list, you’ll find Show Menu Bar.

GOLD STAR TIP: To put the QAT items in a specific order, turn them all off first, then turn them on in the
order you want to see them!

APPLICATION MENU TIDBITS
The big red ‘A’ (I call it the ‘Scarlet Letter’ in training) is the
Application Menu.

MEMO: Wait for the menu to open. If you click the Application
Menu twice, it will close AutoCAD. It’s a ‘feature’.

Access Date
When you open the Application Menu, above the listing of the drawings, is a
dropdown list.
The default is By Ordered List. Take a look at By Access Date which lists
drawings you opened Yesterday, Last Week, Two Weeks Ago, etc.
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GOLD STAR TIP: To keep a drawing from ‘dropping off’ the bottom of
the list, pushpin it!

Close All Drawings
If you have a lot of drawings open, at the bottom of the Application Menu, you’ll find the feature that’ll shut ‘em all
down and save ‘em on the way out!

MEMO: The command CLOSEALL also works.

Number of Files Listed
If you have a history that extends past the listing, there will be a little arrow at
the bottom (or top) that will scroll the list.
To specify the number of drawing files listed in the Application
Menu, go to Options (bottom of the Application Menu) >Open and
Save tab. You can have up to 50 files listed; I set it to 25.

Full Path in the Title Bar
While you’re on the Open and Save tab, I would recommend checking the box to Display
Full Path in Title. Very useful for identifying the drawing network location.

THE RIBBON
The condition of the Ribbon is stored in the current workspace. Once you have configured the Ribbon, save the
workspace. This will give you a ‘fallback’ position should things go sideways.

Ribbon Terms
Heidi Hewitt, AutoCAD Technical Marketing Manager, came up with a wonderfully succinct phrase to define the Ribbon:

“Each tab contains multiple panels, and each panel contains multiple tools.”
Home  Insert  Annotate  Parametric  View  Manage  Output  A360  Express Tools  Layouts

MEMO: Depending upon how your AutoCAD was installed, you may have more or fewer tabs than you see here.
My default collection of Tabs in AutoCAD 2018 are highlighted in the image above.

Chapter One: The User Interface
3

Panels
The Panels are the large sections of the Ribbon. On the Home tab, the panels are
Draw, Modify, Annotation, Layers, etc. The black triangle beside the panel title,
indicates the panel can be expanded to display more tools.

Tools
The Tools are the commands on the panels. Click a black triangle next to the tool to display
similar tools … like the three Revision Cloud options!

Ideas for Personalizing the Ribbon
You will probably want to personalize the Ribbon and optimize the buttons to be the most effective.

The (very tiny) Minimize arrow
There are four settings under that teeny tiny Minimize arrow: The full Ribbon, Minimize to
Tabs, Minimize to Panel Titles, and Minimize to Panel Buttons.
Minimize to Tabs – This setting is the ‘skinniest’ you can make the Ribbon.
Minimize to Panel Titles – Hover over a panel title to display that panel’s content.
Minimize to Panel Buttons – Similar to Panel Titles, but with larger images for the panels.

Ribbon Shortcut Menus
Right‐click on any tool on the Ribbon and you get a shortcut menu with two
very important items: Show Tabs and Show Panels. After making changes
to the Ribbon, you’ll want to update your Workspace.

How to Update Your Workspace
1. After making changes to your Ribbon, click Workspace Switching >Save Current As.
2. Enter a name, or in the drop‐down list, choose the name of an existing workspace, then click Save.
3. When you see the notice regarding replacing the workspace that already exists, click Replace.

TOOLBARS WITH THE RIBBON
The Ribbon is here to stay. Period. And although you no longer have the ‘Classic’ option, I understand you may have
toolbar favorites. Just so you know, you can still have toolbars share the same stage as the Ribbon, but AutoCAD 2014
was the last version to have the ‘Classic’ option on the Ribbon, so here’s how to view your toolbars since then.

How to Display a Toolbar post‐A2014
1. Click the Customize Quick Access Toolbar
dropdown arrow, then click Show Menu Bar
at the bottom.
2. Click Tools >Toolbars >AutoCAD >pick‐one.
3. To make it stay, click Workspace Switching >Save Current As.
4. Enter a name for this workspace or choose one you have already made, then click OK.
From this point forward, when you open AutoCAD, your toolbar – as well as the Menu Bar –
will be displayed.
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PARTIAL OPEN + PARTIAL LOAD
To see just some of the layers of a
drawing use Partial Open, available from
the dropdown arrow beside Open.
[Tip: Smart money says you open the
drawing first and use Layer Walk so you
know what you have, identify the
layers you’ll need, then close it
and start Partial Open.]

Insights
Objects on the layers
selected will be the only
information physically loaded and
displayed, however, all the layer
names for the drawing will be listed
in the Layer dialog, even though the
objects on those layers aren’t
loaded.

Partial Open can only be used on drawings of the same version format.

You will get a notice indicating this

condition.

If a drawing has been partially opened, you can load additional layers using

File >Partial Load. The Partial Load
feature is only available for drawings that have already been partially opened.

In the Partial Load dialog
box is a ‘Pick a window’
button. Use this to specify
the area in which you
want to load additional layers.

When you re‐open a drawing that was saved
in the Partial Open state. Choose to Fully
Open the drawing or Partially Open the
drawing using the previous settings.
The progression below first shows the original drawing, fully opened. The middle figure displays a Partial Open drawing
with the area being specified by picking a window to Partially Load additional layers, as shown in the final figure.
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THE COMMAND LINE
Although it’s been threatened in the past, we still have a Command line!

Floating Command Line: Prompt History & Transparency
If the command line is floating, you can specify how many lines of Prompt
History are displayed as well as the Transparency.

Prompt History
Click the Customize wrench, then enter how
many lines you want to see above the
standard line. I have it set to <1> here.

Transparency
From the Customize wrench, click Transparency to open the dialog box
with the two sliders.

GOLD STAR TIP: To dock the command line, click the small
dot grouping on the left edge, then drag it to the bottom of
the screen until the frame spreads out to both sides.

Customize Wrench
Click on the wrench then hover on Input Settings to display an
assortment of performance features when enabled.
You can also set the Delay Time (in milliseconds) for the
AutoComplete feature, so it doesn’t pop up so quickly.

Recent Commands
There’s a very small little icon that looks like this >_ and if you click it, it will list the last
commands you launched (whatever method you may have used to launch them).

Colorful Option String
When you launch a command with options, such as Rectangle in this example, you can Click an option in the brackets or
enter the letter for the option as you may have done in previous versions. The colors can be modified in Options.

Chapter One: The User Interface
6

Arrow‐Up Command Line Insight
If you hit the Up arrow on your keyboard, you will see your previous commands. Whether you
type your commands and variables, create on‐the‐fly Lisp lines, or select your commands from
any other available method.
If you are not seeing those, you may need to adjust your INPUTHISTORYMODE. That variable
should be set to <15>. To see the configuration options for that variable, you will find those in the System Variable
Editor [Express Tools tab>Tools panel].

THE STATUS BAR
To edit the content of the Status Bar in AutoCAD 2015 – 2017, at the far right end
of it, click Customization (referred to as the ‘Hamburger’ in an Autodesk University
presentation).

The settings displayed here are the ones I typically encourage my customers to use,
many of which are referenced throughout this book.

The Lock UI feature (Lock User Interface) was added
to the Status bar in A2016.
You may want to initially turn this feature on,
confirm sure these options are off (or configured as desired),
then turn off the Lock UI component on the Status bar.

Since that Plot balloon never goes away until you click the
‘X’, launch TRAYSETTINGS and set the Display Time. It works
for the Xref notification, too.
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OTHER USER INTERFACE INSIGHTS
Close
If you have not displayed the Menu Bar (across the top of the screen) the Minimize / Reduce
/ Close icons will appear in the upper right corner of the drawing area (left image).
If you do enable the Menu Bar, the ‘X’ will appear up beside the ‘X’ to close AutoCAD.

GOLD STAR TIP: If you ever ‘lose’ the Model and Layout tabs (Model/Layout tabs
not displayed), go to the View tab >Interface panel >Layout Tabs.

MEMO: Object Snap and Polar are covered in Chapter Two: Creating & Editing.

OPTIMUM OPTIONS
This section presents common of the options my customers find useful. My favorite way to open
Options is to right‐click anywhere in the Command line, then click Options. You could also type OP
[Enter], or go to the Application menu, and click Options at the bottom.

FILES TAB
Trusted Locations
External routines loaded via the
Startup Suite or a 3rd party
application may need to have their
path added to Trusted Locations.
If their path hasn’t been added, a
warning screen will appear.

How to Add a Path to Trusted Locations
1. Go into Options.
2. Expand Support File Search Path.
3. Click on Trusted Locations
4. Click the button for Add, then Browse.
5. Navigate to and select the folder containing the program, then
click OK.
6. When the warning appears regarding ‘read‐only’, click Continue.
From that point forward, you shouldn’t get the Security Concern
warning when launching AutoCAD.
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Automatic Save File Location
The Automatic Save File Location is where you will find the .SV$
files. When AutoCAD crashes, these files are not cleaned out, so
be sure to check this location every few weeks and delete the .SV$
files for drawings that you know are just fine.

Template Settings
Launch AutoCAD or click Qnew, and a copy of the .DWT
file you specified under ‘Template Settings’ will
automatically open.

MEMO: I would recommend a location on your local
drive, not your network for maximum flexibility.
[Coverage of how to configure your Template Settings is
presented in Template Fundamentals following this overview on Options.]

DISPLAY TAB
Color Scheme
By default, the Dark color scheme is how
recent versions of AutoCAD have been
launching. This is totally your call.

Colors
A bit further down on the Display tab,
click Colors. Now click Command line to
display the list of ‘Interface Elements’.
Not very productive, but quite fun.

GOLD STAR TIP: Some features in the Options dialog box have a blue‐and‐yellow icon next
to them indicating a Drawing‐specific setting. That means the feature setting is unique to
the current drawing. Features without that icon are applied to all drawings.

Fade Control
Since locked layers also fade, I would recommend setting this slider for
Fade Control for the Xref Display to <0>.
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OPEN AND SAVE TAB
Disclaimer: The following coverage regarding the backup file, automatic save file and lock files is presented so you can be
more aware of what AutoCAD does with these various file types and the purposes they serve. This is also presented in an
effort to enable those of you without daily technical access or assistance with a more complete understanding of these
files so you can implement efficient ‘housecleaning’ of your systems.
It is always recommended that you backup important drawings to alternative media.

The .SV$ File
The Automatic Save filename includes the name of the file which was automatically
saved and has a file extension of .SV$, and is the same size as the .DWG. When the
‘Automatic Save’ box is checked, you can specify the time interval for the save (the
default is 10 minutes). When it kicks in, you’ll see something like …
Automatic save to C:\Users\CAD Trainer Guy\appdata\local\temp\YadaYada_1_2034.sv$

The .BAK File
If the ‘Create Backup Copy With Each Save’ box is checked, a .BAK file is created from the current .DWG when you Save
the drawing and will overwrite any previous .BAK files of the same name. The .BAK file defaults to the folder in which
the related .DWG file is saved. It, too, is the same size as the drawing file from which it was generated.

The .DWL/2 Files
The .DWL and .DWL2 files – ‘Lock’ files – are automatically created when a drawing is opened. They’re basically ‘traffic
cops’ so if someone else opens that same drawing, the Lock files initiate the “Read Only” notice. Each file is only 1KB
and automatically go away when the drawing they were locking is closed “legally”.
If there’s a system crash (or any other “illegal exit” of a drawing), they stick around since they never received the official
notice the drawing is closed, so if you see one that doesn’t have today’s date, you can delete it.

Drawing Recovery Manager
When you launch AutoCAD after a system crash, this window displays the names
of the files you had open at the time of the crash, along with all their family
members (.BAK & .SV$), if they exist.
Under Backup Files, click on a filename to display the file detail along with a
preview. To open the file, double‐click it. At least this way you don't have to
chase down your .BAK or .SV$ recovery files.

MEMO: After opening the desired file, you will notice a double‐extension,
such as .SV$.DWG. Use Save As and save the drawing as a .DWG (replace the
other one as necessary).

After a Crash …
Ever notice that AutoCAD crashes more frequently after the first time ... (that
day)? I find that if, after re‐launching, you simply Close AutoCAD, you effectively
give AutoCAD an 'attaboy' and it essentially heals all the broken under‐the‐hood
components that were laying around after the crash. Now re‐launch and
remember to Save frequently. It's just zeroes and ones.
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Incremental Save Percentage
Autodesk’s ever‐instructive AutoCAD Evangelist, Lynn Allen, has encouraged us to set
this value to 100 in order to optimize space on your hard drive.

File Open / Full Path in the Title
I would recommend checking the box to Display Full Path in Title. Very
useful for identifying the current drawing’s location.

Number of Files Listed
When you click the scarlet letter (Application Menu), you can
have up to 50 files listed … but 25 may be more reasonable.
If the drawing history extends past the listing, there will be a
little arrow at the bottom (or top) that will scroll the list.

Proxy Objects
Autodesk makes multiple flavors of AutoCAD, specifically AutoCAD Architectural,
AutoCAD Mechanical, etc. You may have opened a drawing in vanilla AutoCAD
and saw a square where a door should be. That square is a ‘Proxy Object’ and
may have been created in AutoCAD Architecture.
You want to see the graphic, but you don’t necessarily need to see the dialog box
telling you there is one.
For information on converting the squares to doors, see Chapter Two: Creating & Editing, ‘Using ‐EXPORTTOAUTOCAD’.

USER PREFERENCES TAB
Right‐Click Customization
Click Right Click Customization button and configure the settings as
shown here for optimum right‐click use.
For those of you remembering the DOS days, these settings optimize
your right‐click so you can take advantage of right‐click menus when
practical.

DRAFTING TAB
AutoTrack Settings
The three settings under AutoTrack Settings specify the
tooltip and the tracking vectors for Ortho and Polar.
You’ll want to experiment with the settings and see
what suits you best.
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Ignore Hatch Objects*
If you need to snap to the intersection of hatch lines ‐ or use any other snap method ‐ (Ex: to
insert a 2' x 4' light fixture block into a reflected ceiling plan), empty this check box, otherwise
your Osnap won't snap to a hatch. [* Variable: OSNAPHATCH <0> = Ignore Hatch Objects ]

3D MODELING TAB
3D Crosshairs
When working in 3D, it’s nice to have labels on the trident cursor,
especially when adding dimensions.

Display Tools in Viewport
Technically, Model space counts as a viewport, so don’t let the name of this section fool ya.

Display the ViewCube We have had a love/hate relationship with this
ever since it came on the scene, so here is where you can specify the
visibility thereof. Later in this chapter is a review of the recently‐introduced
Viewport Controls which includes ViewCube visibility options.
More extensive coverage of the ViewCube is in Chapter Six: 3D Stuff.

Display the UCS Icon There have been some nice changes to the User Coordinate System
[UCS] icon recently, so I’m inclined to leave mine on.
Display the Viewport Controls
The menus in the upper left corner of the drawing window are very useful. These are covered
later in this chapter.

SELECTION TAB
Implied Windowing
The ‘Lasso’
If you DRAG your cursor when
making a window … you will
encounter the Lasso feature.
To toggle that off, turn off Allow
Press And Drag for Lasso.
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Selection Effect Color
By default, select an object and it
glows. You can choose the color of the
from the Selection Effect Color list.
The default is a light blue.
If you use the default (black) background, you have the White selection.
If you use a white background, the selection will be Black and your selection looks
similar to this image.

‘GLOW WORM’ MEMO: For the selection effect glow to … glow,
the Hardware Acceleration must be On (use Graphicsconfig
command).

Selection Preview
By default, as you roll over
objects in your drawing,
the 'Selection Preview'
occurs. This is a great
feature to identify Lines vs.
Pline, Text vs. Mtext,
Blocks vs. parts, etc.

GOLD STAR TIP
If you have a 3D drawing with intensely meshed 3D objects, your system may
get really s‐l‐o‐w, so you may want to turn off both of the Selection Preview.

Click Visual Effect Settings to open a dialog box where you specify the colors
(default = Blue and Green) and the opacity of the selection windows.
Express Tools >System Variable Editor – Here’s the definition of the possible settings for SELECTIONPREVIEW:
Controls the display of selection previewing.
Objects are highlighted when the pickbox cursor rolls over them. This selection
previewing indicates that the object would be selected if you clicked. The
setting is stored as a bitcode using the sum of the following values:
0
1
2

Off
On when no commands are active
On when a command prompts for object selection
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PROFILES TAB
A Profile, primarily, retains the values configured in the Options dialog box. Of primary importance are the contents of
the Files tab which includes all the various paths AutoCAD searches through when files are accessed. [Please note,
Profiles are not available in AutoCAD LT]

MEMO: When you make a profile, AutoCAD not only ‘captures’ the settings at the time you create the Profile, but
continues to ‘record’ any changes made in the Options dialog box. Therefore, to retain the integrity of a default
profile, I would recommend that you create another one that will be your ‘Working’ profile.

How to Create a Named Profile
1. On the Profiles tab of the Options dialog click Add to List, then enter a name for your profile (Dash
and Underscore are OK; no periods, slashes, etc.). Click Apply & Close and you will see the name in
the list . but it's not current.
2. Double‐click on the name (or choose Set Current) to set your profile to current.
3. Click Add to List, then enter a name such as Working, then set it to be current.
Per our understanding, the ‘Working’ profile is recording any changes that – generally speaking – happen in Options. For
example, changing the size of the cursor or the color of the Model space background. What if you now need to go back
to the conditions saved in the original profile (AWBF, in this case)?

How to Restore a Saved Profile to be Current
1. To test this procedure, with your ‘working’ profile current, change something simple like the size of your crosshairs
(Display tab). Close the Options dialog box to confirm the change.
2. Go back to the Profiles tab in Options, then double‐click your default profile name to set it to current. Click OK to
confirm the crosshair size changed to the original size.
Now you will need to update your working profile (which has the modified crosshair size) with the default profile.
3. On the Profiles tab of Options, click Add To List, then enter the name of your working profile and click Apply & Close.
4. When prompted to Replace it, click Yes.
5. Now set the working profile to Current … and you should be good to go!
Should your AutoCAD ever need to be re‐installed or if you want to transport your profile to another computer, you
should export it. The file extension of an exported profile is .ARG.

Chapter One: The User Interface
14

How to Export a Profile
1. Set the profile to be exported to be current.
2. Click Export to open the Export Profile dialog box.
3. Navigate to the desired folder, then enter a name for the profile and click Save. If you ever
need those settings restored, click Import.

MAJOR MEMO: Since a Profile includes pathing information, you should not exchange profiles between versions.

TEMPLATE FUNDAMENTALS
The ‘Template’ file (.DWT) contains your drawing defaults; Units, Layers you always work with, and other settings you
would rather not recreate every time you launch AutoCAD or begin a new drawing.

MEMO: Coverage on the location of the Template was covered a few pages back under Optimum Options.

Settings to Consider Including in Your Template
UNITS
[Status Bar: Units]
To change Precision and Angle settings, use Format > Units.

LIMITS
[Menu bar: Format >Drawing Limits ‐or‐ type LIMITS at the Command line]
The ‘working’ size of your screen is specified in X,Y format. I usually suggest 0,0 for position of the
Lower Left corner and 60’,40’ for the Upper Right corner. Use Zoom >Extents to go to that area.

LAYERS
[Home tab >Layers panel >Layer Properties Manager]
Add the layers you would like to have available in every drawing. Consider adding your company
initials as a layer name prefix; makes it easier to sort.

LINETYPES
[Menu bar: Format menu >Linetype]
Load the linetypes you would like to have available in each new drawing. See Assign a Linetype to a Layer, later in this
chapter.

TEXT STYLES
[Home tab >expanded Annotation panel >Text Style]
Create the various text styles you will need. See Creating a Text Style in Chapter Three.

DIMENSION STYLES
[Home tab >expanded Annotation panel >Dimension Style]
You may want to consider one for each viewport scale you commonly use. See Creating a
Dimension Style in Chapter Three.
Although layout tabs with your title blocks are frequently included in the Template, I recommend that you not include
your title block layouts in the template. A more efficient approach to accessing predefined layouts would be to add a
button to your Tool Palette. As you will see in the following exercise, the Template is simply a drawing that you save
with the DWT extension.
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How to Create the .DWT File
1. Review the coverage about Template Settings under Optimum Options a few pages back. Confirm that you have
specified a path for the Drawing Template File Location [Options >Files tab >Template Settings].
2. Configure your drawing with settings suggested above, then launch the Saveas command.
3. Change the Files of Type to AutoCAD Drawing Template (*.dwt).
AutoCAD automatically jumps to the folder specified in Step 1, above.
4. Enter a File Name for the .DWT file, then click Save, then click OK.
5. Go to Options >Files tab, ‘Template Settings’ node, then expand the node for ‘Default Template File Name for QNEW’.
6. Click the current value (yours may read ‘None’), then click the Browse button to open the
Select File dialog box. The folder should default to the location specified in Step 1.
7. Select the name of your template in the list, then click Open. The path and template
filename should now be displayed under ‘Default Template File Name for QNEW’.
8. Click OK to save your changes and close the Options dialog box.
To test what you did, close your .DWT drawing, then click Qnew in the Quick Access Toolbar. A
copy of your template opens in the same state that you saved it, with whatever Layer you had as
current; same for the Dimension Style and Text Style.
To update the template, after making the desired changes, repeat Steps 2 and 3 above, then select
your template file name in the list. Click Yes when prompted to Replace it.

MEMO: To launch Qnew, you must click the button, not File >New or Ctrl + N.

BE RESPONSIBLE: PLAN AHEAD
When things go sideways with AutoCAD – not IF, but WHEN – it’s really important
that you have the proper backups in place.

Exporting Your AutoCAD Settings
This procedure creates a .ZIP file automatically that you can then Import to
another station or yours if you want to start all over.
After you have configured your AutoCAD just the way you want it – colors, Ribbon
content, etc. – export your settings. A Profile does not contain all the settings; this
is your best One‐Stop‐Shop. Specifically, here are the files the exported .ZIP file
contains:
*.atc/*.aws/*.bmp/*.ctb/*.cuix/*.cus/*.fmp/*.ini/*.lin/
*.mln/*.mnl/*.pat/*.pc3/*.pgp/*.pmp/*.psf/*.shx/*.stb/*.xml

Bottom Line
You can never be too prepared for software slippage. After reading this, hopefully
you are going to the Start button to Export your settings – you will need to close
AutoCAD before you do that, though.
Windows 7 navigation shown on top; Windows 10 navigation shown below.
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FILES OF IMPORTANCE WHEN UPGRADING
After installing the new version,
AutoCAD's Migrate Custom Settings
automatically opens if it sees a
previous version on that computer.
If you Cancel the initial launch, you
launch it separately from Windows’
Start Menu.
Migrate Custom Settings will migrate
your Tool Palette, profiles, custom
menus, icons, hatches, and linetypes,
along with the ever important
acad.pgp which contains your
Command Aliases.
And although the A2018 Migrate
Custom Settings [shown here] will
migrate many of your settings, it’s
always good to back them up, too.

Files You Should Back Up
MASTER.DWT
The .DWT file you established as the template to be used for QNew and when you launch AutoCAD.

MASTER.DWG
This .DWG file will typically contain the same named objects as your .DWT file (Layers, Text Styles, etc.).

MASTER_PLOTSHEETS.DWG or .DWT
This .DWG/.DWT file contains the layouts with your title blocks that you can bring in from DesignCenter or more
effectively from a customized button on the tool palette. Much more productive than using page setups.

*.XTP
Always keep track of your tool palette files: The source file drawing with the blocks on your custom tool palette(s), and
the .XTP tool palette export file(s). Learn how to export tool palettes in Chapter Five: Customizing AutoCAD.

*.SCR and *.LSP
Of course, if you are familiar with creating script or lisp files, these are the first things you will hang onto. You can learn
how to write one‐line .LSP files in Chapter Five: Customizing AutoCAD.

*.SHX
If you have saved or downloaded any non‐native font files, you will want to copy them into the .\Fonts folder of your
new version once it's installed.

*.SVF
Using the System Variable Editor (available from the Express Tools tab and covered in Chapter Two: Creating & Editing),
you can save a .SVF file, then read that file into another system or use it as a backup.
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GOT HELP? USE IT!
AutoCAD’s Help feature is great. And granted, the Internet has
answers, but Home page of the Help window takes you straight to the
sites.

In addition to What’s New and Getting Started videos, many pages
have a Find feature for the command you’re investigating.

‘PLACES’ FOR QUICKER ACCESS
I think it was AutoCAD 2000i that introduced ‘Places’, an editable pane that
lets me put my most frequently accessed folders over on the left side
where the default locations are displayed.
To do this, navigate to the folder containing your drawings, then simply
drag it into the list. Once there, you can drag a folder to the desired
position.

GOLD STAR TIP: To remove an existing item from ‘Places’, such
as History, right‐click on the item, then click Remove.
And finally, if you only want to use the dialog box to
configure your Places collection, if you Cancel, you will be
prompted regarding your efforts (as shown here).

DISPLAY ADJUSTMENTS
Full Screen Workspace
One of my customers asked how to optimize the AutoCAD window and reduce the ‘clutter’. Here’s what I came up with
if you want to optimize your drawing area.

MEMO: Before you do the following exercise, I would recommend you create a Workspace to come back to, per the
instructions on creating a Workspace on the first page of this Chapter.

How to Create a Full Screen Workspace
1. Turn off the layout tabs from the View tab >Layout Tabs.
2. Ctrl + 0 [Clean Screen] ‐ Toggles off all Ribbon and Toolbar elements.
There’s a button for this on the Status bar, too.
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3. Ctrl + 9 ‐ Toggles off (and back On) the Command line.
4. Click the Quick Access Toolbar dropdown, click Hide Menu Bar.
5. Now go to Workspace Switching >Save Current As >ZERO (or whatever).
If you need to see what you’re typing, hit F12 to toggle on Dynamic Input. Hit F12 again to toggle
that feature off after you bring back your Command line.

Disappearing Cursor: Solution No. 1
Have you ever had the cursor disappear in the drawing area, but you can see it on the
toolbars/Ribbon?? You may need to toggle the Visual Style.

Application of the Logic
A. If you selected a Visual Style to view your 3D drawing, you know that by default, the
background color changes.
B. The visibility of the cursor has something to do with the graphics; it was fine a moment ago, and now it’s gone.
C. Therefore, if you change the visual style from what you were using – probably 2D Wireframe – to another style, then
back again, it will effectively ‘reboot’ your cursor graphics.

Disappearing Cursor: Solution No. 2
Or it may be you SNAP setting. Right‐click on Snap Mode on the Status
bar then click Snap Settings to see if the Snap Spacing is really large.

Application of the Logic
A. We will frequently reach for F8 to toggle on Ortho … but miss.
B. F7 toggles the Grid on and off – a visual response that is easily noticed. F9,
however, toggles the Snap which is not so easily noticed.
C. Therefore, if your snap increment is set to a value that is larger than your current display, your cursor won’t move
because there’s no snap point – or maybe very few – in your display. Hit F9 and see if the cursor loosens up a bit.

‘SIGN LANGUAGE’: CURSOR BADGES
The tiny icons beside the cursor are called ‘cursor
badges’. Geometric Constraints (left) and
Selection Cycling (right) join the ones for Locked
layers and the Match Properties paintbrush.
The Erase and Rotate commands have them (shown at left) and even the
Crossing window (shown at right).
If you prefer not to see the new badges beside the cursor, set the variable
CURSORBADGE to <1>, which will disable all badges.
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CLEAN SCREEN … OR OPEN A DRAWING
Across the top of your keyboard, have you ever noticed how close the zero key (0) is in relation to the letter (O)? The
Ctrl + O combination launches the Open command … but the Ctrl + 0 invokes the “Cleanscreen” command and the
Ribbon, toolbars, and palette windows will be toggled off. See the above coverage on Display Adjustments.
The Good News: The Clean Screen icon is a toggle; do it again and those elements come back.

WHEEL MOUSE TIDBITS
There are four functions for the wheel of a wheel mouse:
Roll forward [cursor position specific]:
Roll backward [cursor position specific]:
Push down & drag [push the display in any direction]:
Double‐click ['shrink wraps' the drawing]:

Zoom In
Zoom Out
Pan
Zoom Extents

Insights
A. The variable ZOOMFACTOR [3‐100] adjusts the magnification/reduction of the drawing when rolling the wheel.
B. Begin the Pan command, then hold down the Shift key to achieve an ‘orthogonal’ pan; Left or Right and Up or Down.
The operations are initiated from the cursor position where you launched the Pan command.
C. Hold down Shift first, then push the wheel down like you’re going to Pan, and you get the 3D Orbit feature.
D. The variable ZOOMWHEEL can switch the direction of the zoom. The default <0> will magnify your drawing as you
roll the wheel forward. Set to <1>, you zoom out or away from the drawing when you roll the wheel forward.

PAN AND ZOOM ANTIQUES
A couple questions came up recently that were only able to be solved by some old fashioned features in Pan and Zoom.

Pan a Specific Distance
The wheel mouse dominates many of our pan and zoom needs, but this request was to be able Pan a specific distance.
This requires that you can pick Point A, then move my cursor and enter the distance.
Solution: ‐PAN
Put a hyphen in front of the PAN command and you will be prompted for two points. You can use object snaps, as
well as Ortho or Polar.

Realtime Zoom
The default option of the Zoom command is <real time>. Launch Zoom, press [Enter], then
left‐click and drag your cursor north and south to zoom In and Out gently.

GOLD STAR TIP: The Navigation bar contains an assortment of Zoom options
under the dropdown arrow … wherein you will also find Zoom Realtime.
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NAVIGATION BAR
I will admit that I find that Navigation Bar to be, annoying, but it does have some nice features.
[View tab >Interface panel >Navigation Bar]

Navigation Bar Visibility
The visibility setting is saved in the registry; i.e. permanent. You can set the NAVBAR command
to <OFF>, set the NAVBARDISPLAY variable to <0>, or click the teeny, tiny X in the upper right
corner, it will stay off until you use the command or the variable to bring it back.

Navigation Bar Menu
In the bottom right corner is an itty‐bitty arrow that displays a shortcut menu.
Click Docking Positions, then turn off Link to ViewCube to dock the Navigation
Bar elsewhere on your screen.

Navigation Bar Position
If you keep the Link to ViewCube setting, you can choose one of four screen positions. Disable the Link to
ViewCube setting to position the Navbar anywhere along the perimeter of the screen.

Navigation Bar Tools
Each tool can be removed from the Navbar by right‐clicking on that tool.

Navigation Bar in Paper Space
When you’re in a Layout tab, the Navbar is abbreviated to only display those
features that can actually be used while in Paper space.

Pan tool and Zoom tool (with a menu) If you can’t Pan and Zoom with your wheel
mouse, these two tools are the way to go.

3D Orbit (with a menu) Some folks can push down their wheel like a button, hold down
Shift, and launch 3D Orbit. If that’s not something you can do, this is your go‐to feature.

MODEL SPACE VIEWPORT CONTROLS
The menus tucked into the upper left corner of the active viewport are the Model Space Viewport Controls.
MEMO: If you changed your screen colors, you may not see the
controls in an active viewport. But if you hover in the upper
left corner, the tool tips for the those features will appear.

[Viewport Controls] [figure at left] The left item in that
collection is the Viewport Configuration List which enables you
to split your Model display into multiple viewports (See Split
Viewports in Model Space later in this chapter).
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[Viewport Controls] This item provides access to the common view positions of SW Isometric, SE Isometric, etc.,
similar to the positions available from the View Cube. You can also open the View Manager from this item. If your
current display is something other than one of the defaults, that slot will read ‘Custom View’.

[Visual Style Controls] The last of the three items provides access to the standard list of visual styles; Realistic,
Hidden, etc. Similar to Viewport Controls, the Visual Styles Manager is at the bottom of the list.

TILED DRAWINGS AND THE TASKBAR
Tile Vertically
To copy objects from
drawing ‘A’ into drawing ‘B’,
just drag ‘em.

MEMO: The following
procedure will NOT work if you minimized a drawing.

How to Drag Objects Between Drawings
1. Open the drawings you want to use for this exercise.
2. On the View tab >Interface panel, click Tile Vertically.
3. Select some objects in one of the drawings.
4. Click on a highlighted line of the selected objects (NOT on a grip), then drag it into the other drawing, and release.

GOLD STAR TIP: The variable PICKFIRST must be set to <1> or <2> to drag objects between drawing windows.

Separate Drawings on the Taskbar
The default value for the TASKBAR variable is <1>. This
means when you hover on the AutoCAD icon on the Windows
Status bar, you see the images of all open drawings as seen
on the right, but …
… if you use Alt + Tab to cycle between open applications,
you see a preview of all open drawings as shown below ...

Set the TASKBAR variable to <0> and when you Alt + Tab,
you will only see one AutoCAD preview for the application.
You can then use Ctrl + Tab to cycle between open drawings, or
simply click on the File tab in the drawing window.
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QUICK VIEW LAYOUT ON THE FILE TABS
Hover on a file tab, and a thumbnail
view of all the tabs of that drawing
are displayed!
If there are more tabs than can fit on
the screen, you see an arrow to the
right or left.

GOLD STAR TIP: Type QVD
to display thumbnails of the
open drawings along the
bottom of the screen.

Insights
The current drawing is displayed with a bold, green outline.
Hover on any drawing to see the layout tabs for that drawing.
Hover over a layout tab and the thumbnails increase in size.

Click a layout to set it to current.

Each drawing image has icons in the corner to Save or Close that drawing.
Each Layout image has a Plot and Publish icon in the corner.
GOLD STAR TIP: Use Ctrl + wheel scroll to increase or decrease the image size
of the drawing or layout.
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NEED‐TO‐KNOW TECH TOOLS
Here are some things I have encountered that will help you navigate through some
technical aspects of using AutoCAD.

Run as Administrator
If you get a message that you need ‘Administrator privileges’, consider this: Right‐click
on the AutoCAD icon, then click Run as Administrator.

Copy / Paste a Path
Go to Options >Files tab, then expand Support File Search Path. The path at the top
holds, among other things, the ACAD.PGP file.
If, for example, you need to access that path to copy your ACAD.PGP file, single‐click
on the path, then single‐click on it again. This highlights the path in a text field that
you can Copy using right‐click or Ctrl + C.
Now go to Windows Explorer/File Explorer[Windows key + E]. Click in the path field at
the top of the window, Paste the path and press [Enter] to go to that far distant folder.

Viewing Necessary Settings
In most installations of the Windows OS, a couple Folder
Options need to be reconfigured for optimum navigation in
AutoCAD.

To get to Folder Options in Windows 7, launch My
Computer [Windows key + E], then Organize >Folder and Search Options.

In Windows 10, launch File Explorer [Windows key + E], then View >Options
>Change Folder and Search Options.
On the View tab, check the box to ‘Display the full path in the title bar’, click the
radio button to ‘Show hidden files, and folders, …’ and clear the check box to ‘Hide
extensions for known file types’. Click OK and you’re good to go.

REMEMBERFOLDERS
To designate the folder in which AutoCAD ‘looks’ when you click Open, edit the ‘Start in’,
then set REMEMBERFOLDERS.
The variable REMEMBERFOLDERS has two settings:
<1> Whenever you Open or Save, AutoCAD remembers the folder of the drawing you
opened last. This memory will also carry over after you have closed AutoCAD.
<0> Whenever you Open or Save, AutoCAD ‘looks in’ the folder specified as the ‘Start In’
folder in the AutoCAD 20xx Properties dialog box used to launch AutoCAD. Follow the
instructions below to configure AutoCAD to consistently look in the same folder.
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How to Edit the “Start In” Folder for AutoCAD
1. Right‐click on the AutoCAD icon on your Desktop, then click Properties.
2. In the “Start In” field, enter the name of the folder you want AutoCAD to ‘look
in’ each time you Open or Save a drawing.
3. Click OK, then launch AutoCAD.
4. Change REMEMBERFOLDERS to <0>, then click Open.

WHOHAS
Have you ever wondered which one of your associates has
a drawing open?
Run the WHOHAS command, then choose the drawing of
interest in the Select File dialog box. You are then
presented with notice displaying the path and filename,
along with the person who opened it … and when.

USER COORDINATE SYSTEM ICON AND ITS PROPERTIES
There is a UCSICON command …

… and there is a shortcut menu when you right‐click on it.

Insights
 To see the UCS icon, you will need to turn it ON (from the UCSICON command) or
the View tab on the Ribbon.



A square at 0,0, on the 2D UCS icon means the User Coordinate System [UCS] is set
to World.




The UCS icon position is saved with the Drawing and is viewport‐ and layout‐specific.



To display the UCS icon on the origin, right‐click on the UCS icon >UCS Icon Settings, then
confirm there is a check for Show UCS Icon at Origin.
To force the UCS icon down into the lower left corner,
toggle off Show UCS Icon at Origin.

MEMO: The UCSICON command also has options for displaying the icon on the Origin [OR] or not [N] as seen in the
command line, above.

GOLD STAR TIP: If your UCS icon is not highlighting when you select it, type UCSICON and confirm the
Selectable option is set to <Yes>
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Right‐click on the UCS icon to
display a shortcut menu with a
Properties option where you can
dress it up a bit.



When you are in the 2D
Wireframe visual style, the UCS
icon looks like a stick figure. In
any other visual style, the icon is
a bit more colorful and 3D
looking.

MEMO: If the UCS icon does not anchor to the origin, the graphic of the
icon itself cannot be completely displayed based upon the position of the
UCS origin within the display. Pan your drawing over and the icon will
probably re‐appear on the Origin.



Click on the UCS icon and you see a square grip at 0,0,0 and round grips at the ends of
the axes.



To disable the ability to click on the UCS icon, set the variable UCSSELECTMODE to <0>.

POSITION THE USER COORDINATE SYSTEM ORIGIN [2D]
Before beginning this exercise, open a drawing with a non‐
orthogonal line (or draw one), and make sure the UCS icon
is On, and that you set it to Show UCS Icon at Origin.

How to Position Your UCS Origin and Icon in 2D
1. Click on the UCS icon to display the default square grip at 0,0, and the round grips on
the X and Y axes.
2. Click the 0,0 grip, then specify a point on one of the corners of an angled line.
3. After placing the UCS icon, hover in the round, multi‐function
grip on the X‐axis (or Y‐axis) to display the shortcut menu.
4. In a 2D context, click Rotate Around Z Axis, then rotate the icon
around and snap it to the another endpoint or appropriate snap
location.
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In the following exercise you adjust the view to make the newly‐positioned X‐Axis horizontal.

How to Adjust the View with the User Coordinate System
1. Position the UCS icon along an angled line as shown in the previous exercise.
2. To reorient the view of the drawing, type PLAN at the command line and press [Enter] for the
default UCS condition of <Current>. AutoCAD performs a Zoom >Extents, and adjusts the view
so that the X‐axis is horizontal in the drawing.
3. To put the UCS back to World, right‐click on the UCS icon >World. Now use the PLAN command
to put the X‐axis horizontally in the drawing per step 2, above.

GOLD STAR TIP: Download Trainerguy.LSP from the ‘AutoCAD Downloads’ link on my website,
www.cadtrainerguy.com. Then you can use the UA (UCS Aligned) and UW (UCS World) routines to perform

the procedures above.

SPLIT VIEWPORTS IN MODEL SPACE
Back in TILEMODE <1> days, splitting Model space was commonplace for both 2D
and 3D applications.

How to Setup a Split Screen in Model Space
1. Open a drawing containing 3D objects and
position your view as necessary.
2. From the Viewport controls, click the minus
sign, then click Three: Left.
3. Notice each view has its own Viewport Controls, so you can
set a view for each viewport.
4. It’s particularly helpful to see the edit occur in all views at the same time, too.
In the split screen illustration, I’m moving a component in the 3D view, and the
action is also seen in the 2D view.
In the following exercise, I copy objects from one location on the drawing to
another using split windows.

How to Edit a Drawing Using Split Windows
1. Split the Model space, then activate one of the windows.
2. Launch the desired command in the Source window, such
as Copy.
3. Turn Off Ortho, activate the Target window and you will
see the objects.
4. Place the copy, then press Esc to end the command.
5. To return to the single window configuration, click Single
from the Viewport Configurations dropdown list.
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SPLIT THE SPLIT VIEWPORTS
In addition to splitting Model space, you can adjust the divisions and even split the split viewports.

How to Subdivide a Split Viewport
1. Split Model space into Two: Vertical.
2. At the bottom of the vertical division line is a
teeny, tiny plus sign (+), indicated here in the
enlarged image.
3. Pick it, then drag it – seriously ‐ into either viewport. Depending on
your position in the viewport, the green line will be either horizontal
or vertical. Release the green line to split the viewport.
4. To join two viewports – an option not available in any dialog box or menu – you need the command line version of
the Viewports command: -VPORTS (yes, the hyphen is required).
Command: –VPORTS
Enter an option [Save/Restore/Delete/Join/SIngle/?/2/3/4/Toggle/MOde] <3>: J
Select dominant viewport <current viewport>: Press [ENTER]
Select viewport to join: Click in an adjoining viewport

GOLD STAR TIP: Yes, the TILEMODE variable is still around in case you want to create a macro to flip over to a
Layout or back to Model space!

NAMED VIEWS
When saving a
view by name,
you’re effectively
taking the X,Y of
the lower left and
upper right
corners of the
screen and putting them in a ‘shoebox’ and
labeling it with the view name.
Restore the view and AutoCAD opens the
‘shoebox’ and sets the coordinates up, just the way they were when you saved that view.

MEMO: The View panel of the View tab needs to be enabled to access the View Manager. [See coverage on the
Ribbon earlier in this chapter.] You can also type V to open the View Manager.

How to Save a View by Name
1. Zoom to the drawing area you would like to save by name.
2. Click View Manager to open the View Manager (or type the alias, V).
3. Click New to open the New View / Shot Properties dialog box.
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4. Enter a View Name, then click OK.
5. To set a named view to current, you can either select the
named view from the list in View Manager, then click Set
Current, or simply double‐click the view name.

MEMO: If you launched View Manager prior to zooming to
the desired view, use the Define View Window button
(shown here) to take you back to the drawing so you can
define the view window.

IDEA …
Save a named view in Model space (such as a “3D View”), then
switch to a viewport in a Layout and restore the named view in
that viewport.

GOLD STAR TIP: Since you can have as many named views as you want,
the option to plot a named view is very handy!

View Manager Dialog Box Features
A. On the left side of the View Manager is a tree display of Model, Layout, and Preset Views.
B. The center area contains the selected view’s properties for General, Animation, View, and
Clipping Plane.
C. The Preview area displays a small snapshot of the selected view.

Update Layers
Per the tooltip: “Updates layer information saved with a selected view to
match the layer visibility in the current model space or layout viewport.” It’s
like including a layer state with your view!

Edit Boundaries
Use this button to recreate the view window. Similar to recreating a plot window, the
current view is displayed within a clear window, and the rest of the drawing is behind
an opaque screen.

MEMO: The rectangle you create for the new boundaries will be centered in the
AutoCAD window.

Chapter One: The User Interface
29

CUSTOM VIEW IN VIEWPORT CONTROLS
In addition to the collection of view positions – Top, Bottom, NE Isometric, etc. – named views are
displayed in the Custom Model Views list. You can also create a named view on the fly.

How to Create a Custom View
1. Set the desired view; either 2D or 3D.
2. Click the middle item of the Viewport Controls, then
click View Manager.
3. Click New, enter the name of the view, then click OK.
You will now see ‘Custom Model Views’ displayed in
the Viewport Controls.
4. Hover on ‘Custom Model Views’ to see the list of
named views in that drawing!

SAVE THE UCS BY NAME
If you save the UCS position by name, and associate the named UCS with the named view … when you restore the view,
the UCS position will also be restored.
To follow along, you will need at least one line at a non‐orthogonal angle. (If you're starting from scratch, just draw a
diagonal line.)

MEMO: In the following exercise, you use the UCS command for naming and acquiring the angle of an object. The
UCS is covered more extensively in Chapter Six: 3D Stuff.

How to Save a UCS Position by Name
1. Right‐click on the UCS icon >UCS Icon Setting, then confirm you have enabled Show UCS
Icon at Origin.
2. At the command line, type UCS >Object.
3. When prompted, select a diagonal line for alignment with the X‐axis and
the UCS icon aligns itself to the selected line.
4. Type PLAN and press [Enter], then press [Enter] again for the default
<Current> UCS. AutoCAD will Zoom >Extents.
5. At the command line, type UCS and press [Enter]. To save a UCS position with a
name, type S for the Save option and press [Enter].

GOLD STAR TIP: The Save option is nested within the NAmed option. As in
other expanded option strings, you can enter the characters of the desired
option without going to the expanded view of the option string.
6. Enter a name for the UCS. In this example, I’ll name the UCS, ELEVATOR LOBBY.
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You now know how to save a UCS by name, in addition to saving a view by name. The following continues from the
exercise on the previous page where you saved a named UCS, Elevator Lobby. Now associate it to a new named view.

How to Assign a Named UCS to a New View
1. Click the middle item of the Viewport Controls >View
Manager.
2. Click New, enter the name of the view. Notice, under Settings, a named UCS
(alphabetical if you have more than one).
3. Click OK to close View Manager.
4. To test your named view/named UCS combination, return the UCS to World, then use
the PLAN command to send the UCS back to the World Coordinate System.
5. In the Viewport Controls >Custom Model Views, click your
view name … and watch the view and bring the UCS with it!

GOLD STAR TIP: If you save a UCS after
creating the view, in View Manager,
select the named view, then select the
named UCS.

OPTIMIZED VIEWING OF YOUR DRAWING INFO
In the larger figure on the right, the Layer Properties Manager and the Properties palette are docked; one above the
other. Here’s how they did it.

How to Dock Multiple Interface Features
1. Open the Layer Properties Manager and the Properties palette (or any other palette).
2. Right‐click on the title bar of each palette you are using, and make
sure Allow Docking is checked.
3. Dock one of the windows to either the left or
right side.
4. Drag the second window onto the lower half of
the docked window until the boundary changes
to a rectangle that’s smaller than the docked
window, then release your cursor.

MEMO: When you turn off docked palettes,
they will return to their docked position when
you turn them back on!
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LAYER PROPERTIES HEADER ORGANIZATION
Once I was asked about organizing and
displaying the column headers in the
Layer Properties Manager.
You can either drag a column to a new
position, or right‐click on the line of
column headers and click Customize.
I think you can take it from there.

OFF VS. FREEZE
Layers are the lifeblood in AutoCAD, and efficient management thereof is the key to your own quality of life; specifically,
your sanity.
When a layer is Off, you cannot see the objects on that layer. When a layer is Frozen, you cannot see the objects on that
layer. So, what is the difference between turning a layer OFF or FREEZING it?

Procedure
The Off and Freeze commands are on the Layers panel of the Home tab. Click the command,
then click an object that is on the layer you want to turn Off or Freeze.
Or, if you know what layer you want to turn Off or Freeze, you
can choose the icon from the layer dropdown list for that layer.

Singular Similarity
The objects on layers that are Off or Frozen cannot be seen.

OFF Conditions
A. Objects on layers that are turned Off are still taken into consideration upon a Zoom >Extents.
B. “Global” result; contents of a layer that is turned Off are not visible in Model space or in a Paper space viewport.
C. Turn a layer back On and a Regen of the drawing will not occur, but the objects will be visible.
D. Turn Off the layer on which a block has been inserted and the block is still visible.

FREEZE Conditions
A. Objects on layers that are FROZEN are not taken into consideration upon a Zoom >Extents.
B. Objects in a viewport can be Frozen independently of objects in Model space using
the Freeze or Thaw in Current Viewport icon.
C. When a layer is Thawed, a Regen of the drawing will occur.
D. Freeze the layer on which a block has been inserted and the block will no longer be visible.
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FREEZE INDIVIDUAL LAYERS WITH LAYER FREEZE
Setup. A block can be created on one or more layers. However, there is a very real possibility that the
block could be inserted on a totally different layer, such as A‐FURN.

Dilemma. When using Layer Freeze, what if the entire drawing appears to freeze or there is no
response to the selection.
The Layer Freeze button works in both Model or Paper space, and can be used in place
of clicking the ‘Freeze or Thaw in Current Viewport’ icon in the layer dropdown list.
Since the freezing of layers is unique in each drawing, it’s important to understand the
mechanics of making it work the way you want regardless of the circumstances. This procedure is to be used once you
have launched Layer Freeze.

How to Adjust the Setting for Layer Freeze
1. After getting an ‘unexpected result’ when selecting an object to freeze, if necessary, use the Undo option of the
command to restore the previous layer condition … but don’t hit ESC!
2. Enter S for the Settings option.
3. Enter B for Block Selection.
4. Identify the option that is causing the ‘unexpected results’ … it will be at the end of the option string and will either
be <Entity> or <Block>.
5. Enter the alternative option to the one that is currently set, then continue to pick objects in the drawing to Freeze.

MEMO: You may encounter some drawings in which the opposite may be true. Bottom line, set the Block Level
Nesting to the one that works.

GOLD STAR TIP: After using Layer Freeze to freeze layers, you can use the Layer Previous
command to return to the previous layer configuration.

Another Consideration when Using Layer Freeze in a Viewport
Most of my customers do space plans for corporate facilities. Frequently, they have more
than one viewport and want to freeze components in one viewport, but not in the other.
That’s exactly what the Freeze feature will do … if it’s configured that way.

How to Configure Layer Freeze for Viewports
1. Launch the Freeze routine – Home tab >Layers panel – and you may see the following:
Current settings: Viewports=Off, Block nesting level=Entity
Select an object on the layer to be frozen or [Settings/Undo]:

2. If the Viewports setting is Off (per the above emphasis), enter S for the Settings.
3. Enter V for the Viewports option, then set the condition to Vpfreeze:
Enter setting type for [Viewports/Block selection]: V
In paper space viewport use [Freeze/Vpfreeze] <Freeze>: V
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LAYER PREVIOUS
The Layer Previous button can be a real time saver and is, at its core, a Layer‐specific ‘Undo’.

How to Use Layer Previous
1. Open a drawing, then make a new layer, give it a color and make it current; this will be our
testing layer.
2. Change the Color of any other layer in the current drawing, but don’t make that layer current.
3. On our test layer, draw a small rectangle somewhere.
4. Click Layer Previous and the rectangle remains, but the color of the layer you changed is restored.
5. Freeze several existing layers, then Rotate the rectangle.
6. Click Layer Previous and the previously frozen layers are thawed … but the rectangle is still rotated!

LAYER ISOLATE & LAYER LOCK
Another handy pair of layer manipulation features are Layer Isolate and Layer Lock.

Layer Isolate
On the Layers panel, click Layer Isolate, then select the layers you want to remain On, press [Enter] and
the objects on layers that were not selected are turned Off. Although Layer Isolate includes a Lock & Fade
feature, I recommend using the command as originally intended ‐ to simply turn Off layers not selected.

MEMO: Layer Isolate will result in ‘unexpected results’ if you select an Xref or a Block that is being used as a base
plan. Basically, you can’t use Layer Isolate on multi‐layer entities.

Layer Lock
Layer Lock is on the expanded Layers panel. Objects on locked layers are
visible, but not selectable/editable.
Launch the command, click on a layer you want to lock. When you hover
over an object on that layer, you see a small padlock icon.

By default, a locked layer color will fade a bit. This is controlled by the slider bar on the
expanded Layers panel. The default is 50; the greater the number the greater the fade.

GOLD STAR TIP: If you encounter ‘unexpected results’, click Layer Previous to return to the
previous layer condition.
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Locking Layers with a Crossing Window
Curiously, you can only select the objects on the layers to be locked one at a time, by default; there’s no option to use a
Window or Crossing window.
The following solution uses the command line version of the Layers command by putting a hyphen first: ‐LA.

How to Lock Layers with a Crossing Window
1. At the command line, enter ‐LA to display the options, one of which is [./LOck/.]
2. Enter LO to launch the LOck option, and you get the following prompt:
Enter name list of layer(s) to lock or <select objects>:
3. Press [Enter] to select objects … and you can now select objects with a regular or a Crossing Window!

VIEW LAYERS WITH LAYER WALK
Probably the most valuable tool in the Layers arsenal is Layer Walk. With this
command you can display layers one at a time or by selection, Purge layers with
nothing on them, filter layers by a common prefix, and save layer states.

Layer Walk Dialog Box Insights

Layers that are highlighted in the listing are On in the drawing.
Layers that are not highlighted are either Off or Frozen.
If the Restore On Exit check box is checked (as shown), when you
click Close, AutoCAD restores the layer condition to what it was
prior to launching Layer Walk.

 If the Purge button is ‘live’ (as shown), one or more of the
selected layers can be purged.

The Select Objects button enables you to select the objects of
interest in the drawing, then the Layer Walk dialog box returns,
highlighting the names of the layers in the selection.

How to Review the Content of Each Layer
1. Scroll to the top of the list and click on the top layer.
2. Continue to click on each layer in the list, or use the Down arrow key on your keyboard to ‘walk through’ the list of
layers. In the drawing area, the contents of each layer you select will be turned on.

MEMO: Even layers that are Frozen will display the objects contained on that layer when selected.

How to Select Multiple Layers to View
A. You can either Click + Drag to select several layers at once.
B. Use the Ctrl key to select random layers
C. Click the first layer, then hold down the Shift key and click the last layer in a range.
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Key Features of the Layer Walk Shortcut Menu.
There are two primary features of the Layer Walk shortcut menu that will significantly improve
your productivity: Select All and Save Layer State.

How to Use Select All in Layer Walk.
1. Launch Layer Walk.
2. Right‐click anywhere in the list, then click Select All.
3. Clear the check box for Restore on Exit, then click OK.

GOLD STAR TIP: This is THE fastest way to turn On and Thaw all the layers of a drawing.

How to Create a Layer State Using Layer Walk
1. While in the drawing, use any desired method to configure the layers the way you want to see them.
2. Launch Layer Walk.
3. Right‐click anywhere in the list, then click Save Layer State.
4. Enter a name that describes this layer condition, then click OK.
5. Click OK to close the Layer States dialog box.

More Features in Layer Walk
There are some other features tucked away on the dialog box, as well as the shortcut menu, such as…

Inspect
Right‐click in the list of layers, then click Inspect to open a dialog box which shows
how many layers are in the drawing, the number of layers selected, and the number
of objects on the selected layers.

Apply a Filter for Xref Layers or Groupings
Click in the empty edit field at the top of the dialog box and enter the first few
letters of the Xref name or grouping then an asterisk (A‐ANNO* in the figure
shown here), and press [Enter].
All layers matching that criteria are displayed in the drawing, and the listing
only displays those layers.

Hold Selection
Select more than one layer using the Ctrl key for random selections, the Shift key for a range, or simply click and drag
your cursor across the layers you want to select. If you have a long list of layers, it’s easy to forget the layers you may
have selected already, so use Hold Selection!

How to a Use the ‘Hold Selection’ Feature
1. Open the drawing Floor Plan Sample.DWG […\AutoCAD 201x\Sample\Database Connectivity]
2. Launch Layer Walk. The layers that are not highlighted (white) are either Off or Frozen.
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3. Select the layers shown in the figure at right.
4. After selecting the layers, right‐click, then click Hold Selection. An asterisk will
appear beside the selected layers.
5. Scroll down and select the layers named GRIDLN and GRID‐08. To view the
content of both layers, you will need to use Ctrl … which brings us to the point.
When selecting those two additional layers, the original selection set is still
displayed. If you didn’t use the Hold Selection feature, only the GRIDxx layers
would be displayed.
6. Hold the GRIDxx layers, then turn on E‐F‐STAIR and E‐F‐COLUMN.
7. Before you click OK, be sure to clear the checkbox for Restore on Exit.

CREATE A LAYER STATE IN LAYER STATES MANAGER
The point of saving a layer state is to ‘capture’ the
condition of the layer properties; the color, the
visibility condition, etc. A layer state can be saved
when from the Model tab or in a viewport.

How to Create a New Layer State [LAS]
1. Configure your drawing as necessary – furniture
plan, reflected ceiling plan, foundation layers –
whatever.
2. From the Layer
State dropdown
list on the Layers
panel, click
Manage Layer
States to open the
Layer States
Manager.

MEMO: It may be quicker to type the alias LAS.
3. Click New and enter a name for the layer state.
You can also enter a description.
4. Click Close.
5. To preview a layer state, in the Layer States dropdown list, hover on a named layer state. Click on the layer state to
display the layer condition and close the dropdown list.

Assorted Layer State Insights
Here are a few things to consider when creating layer states …

Layer States in Viewports
When saving a layer state for the active viewport, you may find it helpful to designate viewport‐specific layer states with
a prefix such as “V‐Panel Plan”.
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MEMO: If the box for Turn Off Layers Not Found in Layer State is checked, when you
restore a layer state, layers that were added after those layer states were created
will be turned off when a layer state is restored.

Save
Click the Save button to update the selected layer state to include layers you
recently added or turned On/Thawed.

Export
Use Export to create a .LAS file that can be Imported to another drawing.

Import
The Import button enables you to import a previously exported .LAS ‐or‐ a layer state from
any drawing. Under Files of Type you can choose .LAS or .DWG.
When importing layer states from a .DWG, in the Select Layer States dialog box (shown
here), check the layer states to be imported into the current drawing, then click OK.

GOLD STAR TIP: The Layer States Manager can also be launched from
within the Layer Properties Manager.

LAYER STATE LIST … OR CHECKERBOARD?
In the Layer State list, rather than a list, you may have seen what I can
only call a ‘checkerboard’ arrangement, as shown on the left.
Per the previous sections, the Layer States dropdown list typically
shows a vertical list of your layer states, as shown here on the right.

Solution: Restore your Workspace. On the Status bar, click Workspace Switching,
then select the workspace that has the check beside it. That will restore the current
workspace … and restore the Layer State dropdown to a normal, vertical list.

TO ‐ OR ‐ FROM THE CURRENT LAYER
There are two really handy buttons on the Layers panel ‐ Make Object’s Layer Current and Change to Current Layer.

Make Object’s Layer Current [Home tab >Layers panel]
Use this command to set the current layer by selecting an object that’s on the layer you want to
be current.
Example: You just added topographic lines to the site plan on the TOPO layer, and now you need to add more notes
to the NOTES layer. Click Make Object’s Layer Current, click on a text object that’s on the NOTES layer, and that
becomes the current layer.

Change to Current Layer [Home tab >EXPANDED Layers panel]
This is a great editing feature when you need to move objects from one layer to another.
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